Автор Тема: Наушники  (Прочитано 3220 раз)

Gorinich24

  • Новичок
  • *
  • Сообщений: 2
  • Карма: +0/-0
    • Просмотр профиля
Наушники
« : 22 Июль 2010, 12:08:34 »
После подключения наушников, звук на лаптопе идет как через наушники, так и через динамики, как это дело побороть? чтобы динамики отключались при подключении наушников.Cпасибо заранее.  :-)

An_B

  • Старожил
  • ****
  • Сообщений: 297
  • Карма: +47/-4
    • Просмотр профиля
Re: Наушники
« Ответ #1 : 22 Июль 2010, 16:56:07 »
Можно конечно механический вариант.Выключить кнопку на динамике/Выдернуть штекер динамика  :-)
Умен не тот,кто не делает ошибок.Умен тот,кто умеет легко и быстро исправлять их.

RuLine

  • Новичок
  • *
  • Сообщений: 11
  • Карма: +0/-0
    • Просмотр профиля
Re: Наушники
« Ответ #2 : 24 Июль 2010, 05:40:15 »
Присоединяюсь к вопросу, только на десктопе, хотелось бы чтобы акустич. система переставала работать при включенных наушниках.
Или еще лучше, я хотел бы постояннно выбирать черех что выводить звук (аля смена раскладки клавиатуры) :-D

gidiara

  • Пользователь
  • **
  • Сообщений: 59
  • Карма: +11/-22
    • Просмотр профиля
Re: Наушники
« Ответ #3 : 24 Июль 2010, 13:07:25 »
необходимо установить это:
wget http://www.linuxant.com/alsa-driver/....0_all.deb.zip
 и примерно вот так установить:
unzip alsa-driver-linuxant_1.0.23.0_all.deb.zip
gdebi-gtk alsa-driver-linuxant_1.0.23.0_all.deb
 Возможно, исчезнет значок громкости из трея, найдите его в меню и вставьте снова.

RuLine

  • Новичок
  • *
  • Сообщений: 11
  • Карма: +0/-0
    • Просмотр профиля
Re: Наушники
« Ответ #4 : 24 Июль 2010, 19:12:28 »
Запрос HTTP послан, ожидание ответа... 404 Not Found
2010-07-24 22:04:53 ОШИБКА 404: Not Found.

 :-)

gidiara

  • Пользователь
  • **
  • Сообщений: 59
  • Карма: +11/-22
    • Просмотр профиля
Re: Наушники
« Ответ #5 : 24 Июль 2010, 21:52:06 »
http://www.linuxant.com/alsa-driver/
 отсюда скачаете deb пакет.  :-D

RuLine

  • Новичок
  • *
  • Сообщений: 11
  • Карма: +0/-0
    • Просмотр профиля
Re: Наушники
« Ответ #6 : 26 Июль 2010, 10:43:36 »
Да я пошутил)  насчет ссылки)

вот только глупы вопрос у меня все же есть) а как назывался этот регулятор громкости и где он  был в мееню, а то в упор не вижу  :-(

gidiara

  • Пользователь
  • **
  • Сообщений: 59
  • Карма: +11/-22
    • Просмотр профиля
Re: Наушники
« Ответ #7 : 26 Июль 2010, 21:48:38 »
делаю магические пассы и... система-параметры-звук! можно на него ПКМ кликнуть и выбрать пункт №1 -добавить эту кнопку на панель.
 Большое пожалуйста на ваше огромное спасибо!  *CRAZY*

RuLine

  • Новичок
  • *
  • Сообщений: 11
  • Карма: +0/-0
    • Просмотр профиля
Re: Наушники
« Ответ #8 : 27 Июль 2010, 16:42:20 »
Все бы хорошо) и огромнейшее спасибо плавно перекачевало бы к вам, но блин это не тот регулятор( при нажатии на этот появляется окно параметров, вместо маленького ползунка(

gidiara

  • Пользователь
  • **
  • Сообщений: 59
  • Карма: +11/-22
    • Просмотр профиля
Re: Наушники
« Ответ #9 : 27 Июль 2010, 20:04:32 »
1. можно установить gnome-volume-control-applet
и добавить в автозагрузку: система-параметры-запуск. приложения
2. можно и проверить что же случилось и пойти система-администр.-службы, найти alsa-utils.
3. можно вообще установить kmix из kde и прописать в автозагрузку
  P.S. Это над нами так убунта измывается или прикалываетесь? ;-)

RuLine

  • Новичок
  • *
  • Сообщений: 11
  • Карма: +0/-0
    • Просмотр профиля
Re: Наушники
« Ответ #10 : 28 Июль 2010, 11:09:55 »
Если еще не читали мою тепу про VLC, то да, после перехода на ubuntu 10.04 (mint-9) неизвестно откуда посыпались проблемы, которые еще и редко у кого встречаются(

хакер Шило

  • Старожил
  • ****
  • Сообщений: 308
  • Карма: +77/-20
  • Я скромен, потому что я гений. (Наум Каштаньер)
    • Просмотр профиля
Re: Наушники
« Ответ #11 : 13 Август 2010, 22:13:44 »
Иногда с наушниками встречается еще и вот такой геморой. На остальных не знаю, но на тех, где одно гнездо и для микрофона и для наушников - это точно. При включении в такое гнездо наушников в динамиках звук исчезает, а вот в наушниках не появляется.
Как удалось выяснить, проблема в том, что переключение идет программным методом.

На моём новеньком ASUS eee PC 1001px эта проблема появилась и пришлось её "бороть". Все достаточно тривиально...

Открываем терминал и в нем Midnight Commander: sudo mc
Ищем вот такой файлик: /etc/modprobe.d/alsa-base.conf
В нем вставляем вот такую строку (я вставил в конце файла, но где вроде значения не имеет):
options snd-hda-intel model=lifebook
Сохранить и перегрузиться. Все должно работать!

Теперь какие значения могут быть у параметра "model"...
Посмотреть их можно в файле: /usr/share/doc/alsa-base/driver/ALSA-Configuration.txt.gz

Gorinich24

  • Новичок
  • *
  • Сообщений: 2
  • Карма: +0/-0
    • Просмотр профиля
Re: Наушники
« Ответ #12 : 22 Август 2010, 19:08:35 »
 :-D спасибо канеш за ответы) все решил довольно просто) в свойствах аудио стояло Analog Stereo Duplex, поставил обычный Analog Stereo Output. проблема решена, можно закрывать сабж)