Автор Тема: Plymouth -- графический загрузчик или скрытый террорист?  (Прочитано 2321 раз)

Brego

  • Ветеран
  • *****
  • Сообщений: 566
  • Карма: +93/-1
  • Перебьемся
    • Просмотр профиля
    • MintMem
Разбираясь с нестабильным временем загрузки системы (то 25-27 сек., то 75-80 сек), я полюбопытствовал, кто такое plymouth. До этого знал только, что это замена upsplash, вроде бы более продвинутый графический загрузчик. Синаптик сообщил о том, что это пакет с флагом "необязательный", версия 0.8.2-2-1mint3(isadora).
И тут я по наитию надавил "отметить для удаления", хотя вовсе не собирался его удалять. После чего началось интересное...
Синаптик сообщил, что придется удалить заодно и еще некоторые пакеты. Я начал их считать, сотни через две сбился и прикинул на глаз, что их около пятисот. Среди них -- выбираю наугад -- такие, например, как cups, cron, hal, firefox, gdebi, gimp, gksu, gvfs, nautilus, gnome, gedit, acpi, aptdaemon... И т.д, и т.д... И наконец -- уже вполне логично (крушить так крушить!) -- и ядро 2.6.32-32.
Запросил апт:
apt-cache -v show plymouthтот пояснил, что есть три пакета с таким именем, один, как и сообщал синаптик, имеет флаг "optional",  а вот два других -- 0.8.2-2ubuntu2 и 0.8.2-2ubuntu2.2 -- совсем другое дело: "Priority: required". Более того,
apt-cache rdepends plymouthназвал среди разных splash-темок пакет mountall. Этот обязательный для системы пакет, оказывается, зависит от plymouth!
Поверхностное гугление по рунету пока ничего не дало. Буду продолжать гуглить, но, может, кто-нибудь из форумчан знает подоплеку этого темного и таинственного дела?
"Следующая эпоха началась с сожжения всех хроник вместе с хронистами". С. Лем