Автор Тема: Обновления ПО дистрибутива у которого закончилась поддержка  (Прочитано 19649 раз)

mimoprohodil

  • Гость
Всё лежит на http://old-releases.ubuntu.com/ubuntu/dists/

Эх, ёлки-иголки, где ж вы раньше то были с этими гуглами... уже поставил mint 15. 

camope3

  • Постоялец
  • ***
  • Сообщений: 103
  • Карма: +1/-1
  • Сижу на ветке Ubuntu...
    • Просмотр профиля
то есть, можно и Росинку 9 воскресить, с ее Гномом 2? и все будет ставиться?
... не хватает теплого лампового Гнома...

Brego

  • Ветеран
  • *****
  • Сообщений: 566
  • Карма: +93/-1
  • Перебьемся
    • Просмотр профиля
    • MintMem
То есть что значит "воскресить"!? У меня она уже три года как основная ось, дай бог другим такого здоровья.
"Следующая эпоха началась с сожжения всех хроник вместе с хронистами". С. Лем

camope3

  • Постоялец
  • ***
  • Сообщений: 103
  • Карма: +1/-1
  • Сижу на ветке Ubuntu...
    • Просмотр профиля
То есть что значит "воскресить"!? У меня она уже три года как основная ось, дай бог другим такого здоровья.

я имел в виду то, что срок поддержки U 10.04 истек и многие, в том числе и я, перешли на свежие оси и забыли про старые... а ведь в той же Росинке 9 старый добрый Гном 2... вот и переход обратно на Р9 для меня как "воскрешение" системы... как долго этот сторонний репозиторий будет жив?
... не хватает теплого лампового Гнома...

Brego

  • Ветеран
  • *****
  • Сообщений: 566
  • Карма: +93/-1
  • Перебьемся
    • Просмотр профиля
    • MintMem
как долго этот сторонний репозиторий будет жив?
Судя по списку осей, начинающемуся с Ubuntu 4.10 (Warty Warthog) -- приблизительно вечно  :-)
Но дело, конечно, не в этом. В конечном счете прав Kamrad: весь вопрос в том, зачем вам система и насколько интенсивно вы будете с ней работать. Можно и без реп обойтись, если освоить несложный механизм установки пакетов из исходников или компиляцию их в deb-пакеты.
ИМХО: и коснеть в старом, и гнаться за самым новым -- одинаково нехорошо. Лучше подбирать ось "по себе".
"Следующая эпоха началась с сожжения всех хроник вместе с хронистами". С. Лем

Single

  • Пользователь
  • **
  • Сообщений: 63
  • Карма: +2/-0
  • LMDE x86 @ HP620 Laptop
    • Просмотр профиля
то есть, можно и Росинку 9 воскресить, с ее Гномом 2? и все будет ставиться?

"Воскресить", в смысле заново поставить, конечно можно. И все из этих репозиториев можно поставить. Однако есть большой нюанс: все же убунта 10.04 уже давно снята с поддержки, и ни нового ПО, ни более новых версий вы там не найдете.

Так что, если вам вдруг понадобится более новая версия, например, любимого браузера, чтоб был с более полноценной поддержкой HTML5, либо более новый компилятор, либо еще что-то - то надо искать в другом месте (в гугле, например), или вообще компилить из исходников, что тоже не всегда вариант, ибо часто может оказаться, что новые программы потребуют и новых библиотек, и в конечном итоге обновление компонетна может оказаться равносильным обновлению всей системы.

А так, вообще, для дома и офиса Росинка 9 - самое то, ибо мегастабильна и допилена до зеркального блеска.

Кстати, для росинки 9, насколько я понимаю, надо репы не от Natty, а от Lucid - еще на 2 версии старее

# Основное, необходимо
deb http://old-releases.ubuntu.com/ubuntu/ lucid main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ lucid-updates main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ lucid-security main restricted universe multiverse

# Опционально, бэкпорты. В общем-то тоже рекомендуется.
deb http://old-releases.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
# Предлагаемые обновления
#deb http://old-releases.ubuntu.com/ubuntu/ lucid-proposed main restricted universe multiverse
« Последнее редактирование: 02 Август 2013, 15:48:47 от Single »
Мечтай так, как будто будешь жить вечно. Живи так, как будто умрешь завтра.

Kiset

  • Новичок
  • *
  • Сообщений: 24
  • Карма: +0/-0
    • Просмотр профиля
Перестали обновляться пакеты. Форматнул разделы, установил по-новой. Версия "Linux Mint 11 Росинка (Std) x86 (27 августа 2011г.)" Та же ситуация.
В менеджере обновлений при обновлении списка пакетов, выдаёт:
[spoiler]Не удаётся обновить список пакетов 
ERROR###ERROR###ERROR###ERROR###ERROR###ERROR###ERROR
W:Failed to fetch http://security.ubuntu.com/ubuntu/dists/natty-security/main/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://extras.ubuntu.com/ubuntu/dists/natty/main/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://security.ubuntu.com/ubuntu/dists/natty-security/restricted/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://security.ubuntu.com/ubuntu/dists/natty-security/universe/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://security.ubuntu.com/ubuntu/dists/natty-security/multiverse/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://archive.ubuntu.com/ubuntu/dists/natty/main/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://archive.ubuntu.com/ubuntu/dists/natty/restricted/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://archive.ubuntu.com/ubuntu/dists/natty/universe/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://archive.ubuntu.com/ubuntu/dists/natty/multiverse/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://archive.ubuntu.com/ubuntu/dists/natty-updates/main/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://archive.ubuntu.com/ubuntu/dists/natty-updates/restricted/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://archive.ubuntu.com/ubuntu/dists/natty-updates/universe/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://archive.ubuntu.com/ubuntu/dists/natty-updates/multiverse/binary-i386/Packages  404  Not Found
, E:Some index files failed to download. They have been ignored, or old ones used instead.[/spoiler]
Отмечаю для установки один из существующих: "mintmenu" новая версия 5.2.4, старая версия 5.2.2-2
Нажимаю "Установить обновления". Всплывает окно:
"Данное обновление приведёт к дополнительным изменениям. Эти пакеты (7) будут установлены..."
Жму "ок". Менеджер просто закрывается!
Повторяю попытку. Отмечаю для установки ВСЕ пакеты. Продвигаюсь на шаг дальше. Всплывает
"Краткое описание: Внимание! Вы собираетесь установить программу, подлинность которой не может быть определена...".
Жму "Применить". Всплывает сообщение:
"Не удалось получить некоторые пакеты с серверов. Желаете ли Вы продолжить, пропустив эти пакеты?"
Жму "Да".
Тут же ошибка:
[spoiler]E: Невозможно исправить отсутствующие пакеты
W: Не удалось получить http://archive.ubuntu.com/ubuntu/pool/main/q/qt4-x11/libqt4-test_4.7.2-0ubuntu6.2_i386.deb
  404  Not Found
W: Не удалось получить http://archive.ubuntu.com/ubuntu/pool/universe/q/qt4-x11/libqt4-core_4.7.2-0ubuntu6.2_i386.deb
  404  Not Found[/spoiler] и кнопка "Закрыть"

При следующем запуске Менеджера обновлений всплывает ошибка:
"Невозможно получить все индексы репозитория. Возможно репозиторий больше не доступен или к нему нет доступа из-за сетевых проблем. Будет использована старая версия индекса , если она имеется. В противном случае репозиторий будет игнорирован. Проверьте сетевое соединение и правильность написания адреса репозитория в настройках."
[spoiler]Не удалось получить http://security.ubuntu.com/ubuntu/dists/natty-security/main/binary-i386/Packages  404  Not Found [IP: 91.189.92.190 80]
Не удалось получить http://extras.ubuntu.com/ubuntu/dists/natty/main/binary-i386/Packages  404  Not Found
Не удалось получить http://security.ubuntu.com/ubuntu/dists/natty-security/restricted/binary-i386/Packages  404  Not Found [IP: 91.189.92.190 80]
Не удалось получить http://security.ubuntu.com/ubuntu/dists/natty-security/universe/binary-i386/Packages  404  Not Found [IP: 91.189.92.190 80]
Не удалось получить http://security.ubuntu.com/ubuntu/dists/natty-security/multiverse/binary-i386/Packages  404  Not Found [IP: 91.189.92.190 80]
Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty/main/binary-i386/Packages  404  Not Found [IP: 91.189.92.200 80]
Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty/restricted/binary-i386/Packages  404  Not Found [IP: 91.189.92.200 80]
Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty/universe/binary-i386/Packages  404  Not Found [IP: 91.189.92.200 80]
Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty/multiverse/binary-i386/Packages  404  Not Found [IP: 91.189.92.200 80]
Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty-updates/main/binary-i386/Packages  404  Not Found [IP: 91.189.92.200 80]
Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty-updates/restricted/binary-i386/Packages  404  Not Found [IP: 91.189.92.200 80]
Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty-updates/universe/binary-i386/Packages  404  Not Found [IP: 91.189.92.200 80]
Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty-updates/multiverse/binary-i386/Packages  404  Not Found [IP: 91.189.92.200 80]
Some index files failed to download. They have been ignored, or old ones used instead.[/spoiler]

И ещё при обновлении:
"Невозможно получить все индексы репозитория.
Возможно репозиторий больше не доступен или к нему нет доступа из-за сетевых проблем. Будет использована старая версия индекса, если она имеется. В противном случае репозиторий будет игнорирован. Проверьте сетевое соединение и правильность написания адреса репозитория в настройках."
[spoiler]Не удалось получить http://extras.ubuntu.com/ubuntu/dists/natty/main/binary-i386/Packages  404  Not Found
Не удалось получить http://security.ubuntu.com/ubuntu/dists/natty-security/main/binary-i386/Packages  404  Not Found
Не удалось получить http://security.ubuntu.com/ubuntu/dists/natty-security/restricted/binary-i386/Packages  404  Not Found
Не удалось получить http://security.ubuntu.com/ubuntu/dists/natty-security/universe/binary-i386/Packages  404  Not Found
Не удалось получить http://security.ubuntu.com/ubuntu/dists/natty-security/multiverse/binary-i386/Packages  404  Not Found
Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty/main/binary-i386/Packages  404  Not Found
Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty/restricted/binary-i386/Packages  404  Not Found
Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty/universe/binary-i386/Packages  404  Not Found
Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty/multiverse/binary-i386/Packages  404  Not Found
Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty-updates/main/binary-i386/Packages  404  Not Found
Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty-updates/restricted/binary-i386/Packages  404  Not Found
Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty-updates/universe/binary-i386/Packages  404  Not Found
Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty-updates/multiverse/binary-i386/Packages  404  Not Found
Some index files failed to download. They have been ignored, or old ones used instead.[spoiler]
« Последнее редактирование: 03 Октябрь 2013, 19:41:50 от Kiset »
Acer Aspire One
Processor      : 2x Intel(R) Atom(TM) CPU N270   @ 1.60GHz
Memory      : 1012MB (565MB used)
Operating System: Linux Mint 11 Rosinka

Azure

  • Глобальный модератор
  • Ветеран
  • *****
  • Сообщений: 2118
  • Карма: +275/-114
  • Обычно я му-р-р-р-чу
    • Просмотр профиля
    • Exilibris Web Development
Проверьте состояние интернета — открывается ли адрес http://archive.ubuntu.com/ubuntu/dists/natty и др.

И пользуйтесь Поиском иначе этот вопрос будет повторятся и повторяться…
« Последнее редактирование: 03 Октябрь 2013, 19:28:44 от Azure »

camope3

  • Постоялец
  • ***
  • Сообщений: 103
  • Карма: +1/-1
  • Сижу на ветке Ubuntu...
    • Просмотр профиля
решил я поностальгировать в Росинке 9 и, очень приятно, оно живое:

Вас что, на гугле забанили?

Всё лежит на http://old-releases.ubuntu.com/ubuntu/dists/

В sources.list нужно добавить следующее:
# Основное, необходимо
deb http://old-releases.ubuntu.com/ubuntu/ natty main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ natty-updates main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ natty-security main restricted universe multiverse

# Опционально, бэкпорты. В общем-то тоже рекомендуется.
deb http://old-releases.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse
# Предлагаемые обновления
#deb http://old-releases.ubuntu.com/ubuntu/ natty-proposed main restricted universe multiverse

Ну и, естественно,
sudo apt-get update

Удачи!

успешно добавил репозитории и обновил кэш (заменил natty на lucid)! стоит заметить что на свежей машине Р9 летает как ракета и конечно же, родной Гном 2! жаль, не получилось поставить ядро 3.8...
... не хватает теплого лампового Гнома...

IDaXaR

  • Новичок
  • *
  • Сообщений: 1
  • Карма: +0/-0
  • Я новичок в Linux Mint Росинке...
    • Просмотр профиля
Не получается установить Steam на 11 Росинку.

Ghost

  • Старожил
  • ****
  • Сообщений: 466
  • Карма: +31/-2
  • прошу не прибавлять и не убавлять мою карму
    • Просмотр профиля
Вы  бы еще на 9-ую попробовали поставить.... Тут нужна не менее 13-ой версии Mint или 12 Ubuntu... На сайте Steam (откуда вы и скачали файл) всё об этом написано
« Последнее редактирование: 04 Ноябрь 2013, 15:39:03 от Ghost »

Trump

  • Новичок
  • *
  • Сообщений: 19
  • Карма: +0/-0
    • Просмотр профиля
    • TRUMP`LINE
Никак не могу установить grub customizer,  ни в терминале, ни в менеджере программ, что за дела ?. (Росинка 11)
« Последнее редактирование: 07 Ноябрь 2013, 13:07:12 от Trump »
Windows 7, Windows Embedded 8.1 Industry Pro, Linux Mint 16 MATE.
--------------------------------------------------------------------------------
Лучше сделать и жалеть, чем жалеть, что не сделал.

хакер Шило

  • Старожил
  • ****
  • Сообщений: 308
  • Карма: +76/-20
  • Я скромен, потому что я гений. (Наум Каштаньер)
    • Просмотр профиля
Никак не могу установить grub customizer,  ни в терминале, ни в менеджере программ, что за дела ?. (Росинка 11)

В гугле забанили? :-D
Просто в репы он не включен как таковой. А потому...
sudo add-apt-repository ppa:danielrichter2007/grub-customizer
sudo apt-get update
sudo apt-get install grub-customizer

Trump

  • Новичок
  • *
  • Сообщений: 19
  • Карма: +0/-0
    • Просмотр профиля
    • TRUMP`LINE
Гугл не причём и в терминале это делал и отсюда. Эффект - 0. Поэтому и вопрос. В 2013 устанавливаю влёт.
Windows 7, Windows Embedded 8.1 Industry Pro, Linux Mint 16 MATE.
--------------------------------------------------------------------------------
Лучше сделать и жалеть, чем жалеть, что не сделал.

Trump

  • Новичок
  • *
  • Сообщений: 19
  • Карма: +0/-0
    • Просмотр профиля
    • TRUMP`LINE
А это в терминале
Windows 7, Windows Embedded 8.1 Industry Pro, Linux Mint 16 MATE.
--------------------------------------------------------------------------------
Лучше сделать и жалеть, чем жалеть, что не сделал.