Автор Тема: HD Video  (Прочитано 14165 раз)

dmitry287

  • Старожил
  • ****
  • Сообщений: 361
  • Карма: +45/-2
    • Просмотр профиля
HD Video
« : 07 Апрель 2010, 14:11:00 »
Попробовал на днях разные фильмы HD форматов,и обнаружил неприятное явление,фильмы разрешением 1280х720 проигрываются нормально,а full HD 1920x1080,без слез смотреть нельзя,периодически сплошное слайд-шоу...Притом это не зависит от установленых или неустановленых проприетарных дров.
Перепробовал разные дистрибутивы росинки,убунты,мандривы и т.д.-результат одинаковый :'(
На винде никогда этих проблем небыло,все HD форматы проигрывались,как говорится ровно и гладко.На всякий случай мое железо,видеокарта ати HD4200 бортовая,процессор AMD Athlon x4 620, 2.6 ГГц, ОЗУ 4гб,из них 512м отдано видюхе.
Хотелось бы услышать отзывы как у других пользователей с этим обстоят дела,неужели это только у меня такие проблемы. 
« Последнее редактирование: 30 Июнь 2010, 17:04:28 от dmitry287 »
Gigabyte GA-790XTA-UD4,Athlon II x4 620 2.6 GHz,4Gb DDR3,Video Gigabyte GT240 512M,HDD 3x500 Gb & 160 Gb

krabat

  • Новичок
  • *
  • Сообщений: 22
  • Карма: +1/-0
    • Просмотр профиля
Re: HD Video
« Ответ #1 : 29 Июнь 2010, 11:10:25 »
Скачал фильм в Full HD. Естественно,смотреть не возможно,машина старая-старая.Видео карта AGP Radeon 1050 (кажется,на Виндоус драйвера для  нее ставил),процессор Celeron 1.8 (сокет 478)
Есть ли лекарство от сей проблемы кроме как новую машину покупать/собирать?

Hyper

  • Новичок
  • *
  • Сообщений: 23
  • Карма: +9/-0
    • Просмотр профиля
Re: HD Video
« Ответ #2 : 29 Июнь 2010, 12:15:33 »
Скачал фильм в Full HD. Естественно,смотреть не возможно,машина старая-старая.Видео карта AGP Radeon 1050 (кажется,на Виндоус драйвера для  нее ставил),процессор Celeron 1.8 (сокет 478)
Есть ли лекарство от сей проблемы кроме как новую машину покупать/собирать?
К сожалению, только новую машину. Без вариантов.

Hromin

  • Глобальный модератор
  • Ветеран
  • *****
  • Сообщений: 590
  • Карма: +145/-4
    • Просмотр профиля
Re: HD Video
« Ответ #3 : 29 Июнь 2010, 22:23:30 »
Цитировать
К сожалению, только новую машину. Без вариантов.
К моему ещё бОльшему сожалению, просмотр фильмов в Full HD качестве под Linux, на данный момент, может оказаться проблематичным и на "нормальном" железе. Встречал частные варианты решений этой проблемы, но только для NVIDIA-карт. Например:
http://linux.ya1.ru/blog/topic/300/
http://www.linuxspace.org/archives/1304

krabat

  • Новичок
  • *
  • Сообщений: 22
  • Карма: +1/-0
    • Просмотр профиля
Re: HD Video
« Ответ #4 : 29 Июнь 2010, 23:00:14 »
Все понял,спасибо.
Пошел раздавать долги и просить милостыню на 6-и ядерный проц от Intel *WALL*

Hyper

  • Новичок
  • *
  • Сообщений: 23
  • Карма: +9/-0
    • Просмотр профиля
Re: HD Video
« Ответ #5 : 30 Июнь 2010, 06:25:38 »
Все понял,спасибо.
Пошел раздавать долги и просить милостыню на 6-и ядерный проц от Intel *WALL*
Самое главное - озаботьтесь покупкой карты класса GeForce не ниже 8400GS - это низшая модель в официальной линейке поддерживаемых vdpau.
 
Встречал частные варианты решений этой проблемы, но только для NVIDIA-карт. Например:
http://linux.ya1.ru/blog/topic/300/
http://www.linuxspace.org/archives/1304
В принципе, все эти частные решения сводятся к одному общему: NVIDIA-VDPAU-MPlayer (плюс GUI к последнему, для удобства - SMPlayer, например).
Собственно, я уже писал, как добился на своей относительно слабой машине приемлимого просмотра HD-контента.

dmitry287

  • Старожил
  • ****
  • Сообщений: 361
  • Карма: +45/-2
    • Просмотр профиля
Re: HD Video
« Ответ #6 : 30 Июнь 2010, 16:26:45 »
Сейчас на Убунте 10.04х386 мне удалось добится что full HD 1920x1080 на бортовой карточке HD4200 на коробочных дровах идет без проблем.
На Росинке9х386 с теми кодеками что там установлены все-таки были подтормаживания и рассыпания на квадратики иногда.
Попытаюсь на пальцах объяснить что я делал:
1.Подключил репозитории VLC,менеджер обновлений сразу предложил мне обновить версию плейера и еще кучку каких-то пакетов,названия я к сожалению не запомнил,плейер обновился до версии 1.2 вместо 1.06 который был установлен из репов Убунты и присутствует в Росинке9.С этими обновлениями full HD 1920x1080 пошло нормально без тормозов и рассыпаний,но возникла другая проблема,во время фильма срабатывал хранитель экрана через заданное количество минут и через 30 мин монитор отключался совсем,несмотря на то что в настройках плейера стояли галочки блокировать хранитель экрана и отключение монитора или как то так.
2.Тогда я удалил новую версию плейера и откатился на старую 1.06,у которой проблем с хранителем экрана и отключением монитора не было.
3.Видимо какие-то обновленные пакеты в системе остались,потому что сейчас VLC1.06 проигрывает те же фильмы full HD 1920x1080 без проблем.
P.S.На Убунте амд64 все пошло нормально сразу на версии VLC1.06 без бубна описанного выше,видимо там используются другие кодеки и пакеты вообще,вернулся на х386 потому что мой принтер Canon IP1000 вряд ли когда нибудь заработает под х64,давно снят с производства дров нет и скорей всего уже не будет.
Gigabyte GA-790XTA-UD4,Athlon II x4 620 2.6 GHz,4Gb DDR3,Video Gigabyte GT240 512M,HDD 3x500 Gb & 160 Gb

пришелец

  • Новичок
  • *
  • Сообщений: 8
  • Карма: +1/-0
    • Просмотр профиля
Re: HD Video
« Ответ #7 : 24 Июль 2010, 13:11:35 »
Подтормаживало на тяжелых FullHD. Отключение "пропускать кадры" в gnome mplayer почти избавило от этой проблемы. А если запускать mplayer с опцией -lavdopts threads=2 , то видео идет совсем плавно. При этом график загрузки у ядер проца становится почти одинаковым.

andrymax

  • Гость
Re: HD Video
« Ответ #8 : 09 Август 2010, 04:32:29 »
Та же проблема - не играет нормально  все файлы HD ts и  некоторые mkv. Ubuntu 9.04 - 10.04.  AMD64 x2 5200+/9500GT wich HDMI/2G.  О видео ts - vlc вроде начинает проигрывать, но потом останавливается, и дальше рывками. Smplayer первую секунду- потом скорость резко падает и все как в замедленной сьемке          Повторю - в основном, это со всеми файлами ts.
Изменение размеров кэша, включение ускорение vdpau в SMplayer не принесло результаты (может не то менял, в смысле кеша?).
« Последнее редактирование: 09 Август 2010, 04:35:13 от andrymax »

gidiara

  • Пользователь
  • **
  • Сообщений: 59
  • Карма: +11/-22
    • Просмотр профиля
Re: HD Video
« Ответ #9 : 09 Август 2010, 12:13:25 »
 Настраивал себе и ещё на 2-х компах, всё идёт и на слабых машинах. Самый простой вариант уже указан- добавить репозиторий VLC вручную и обновить.
 Другие рецепты: http://welinux.ru/post/2651/
 http://wavilen.blogspot.com/2010/02/ati-hd3200igp-hd-ubuntu.html
« Последнее редактирование: 10 Август 2010, 00:08:57 от Hromin »

dmitry287

  • Старожил
  • ****
  • Сообщений: 361
  • Карма: +45/-2
    • Просмотр профиля
Re: HD Video
« Ответ #10 : 09 Август 2010, 17:04:21 »
Для VLC я сделал еще настройки /Ввод и кодеки/Skip H264 in-loop deblocking filter/все
без этой установки на некоторых фильмах все таки имели место подтормаживания и артефакты на некоторых сценах.

gidiara
Можно поподробней,на каком железе,с какими дровами и тд у Вас положительные результаты?
У меня карточка интегрированная в материнку AMD HD4250,в ней есть аппаратное декодирование и транскодирование HD видео.
Но вся беда в том что сколько раз я не пробовал ставить проприетарные дрова все время на фильмах в динамичных сценах получаются горизонтальные изломы изображения,причем не только на HD. Перечитал кучу форумов,перебробывал все настройки и версии дров и плэйеров которые выходили за последнее время,ничего не помогло. На открытых дровах такого нет,поэтому на них и сижу,но на них вряд ли получится реализовать аппаратное декодироание видеокартой...
Gigabyte GA-790XTA-UD4,Athlon II x4 620 2.6 GHz,4Gb DDR3,Video Gigabyte GT240 512M,HDD 3x500 Gb & 160 Gb

dmitry287

  • Старожил
  • ****
  • Сообщений: 361
  • Карма: +45/-2
    • Просмотр профиля
Re: HD Video
« Ответ #11 : 09 Август 2010, 20:44:23 »
http://forum.ubuntu.ru/index.php?topic=98980.0

Здесь предлагается еще один способ как избавится от тормозов на HD фильмах,если железо не поддерживает аппаратное декодирование видеокартой.Кто попробует отпишитесь плиз.
Gigabyte GA-790XTA-UD4,Athlon II x4 620 2.6 GHz,4Gb DDR3,Video Gigabyte GT240 512M,HDD 3x500 Gb & 160 Gb

gidiara

  • Пользователь
  • **
  • Сообщений: 59
  • Карма: +11/-22
    • Просмотр профиля
Re: HD Video
« Ответ #12 : 09 Август 2010, 22:25:08 »
to dmitry287 Проблем нет на дровах от ATI 10.7, видео моб. HD 5740, загрузка проца при просмотре Full HD - 20-25%, плеер VLC,  репозиторий подключал через UbuntuTweak, os ubuntu 10.04. Хорошие результаты были достигнуты на 4xxx серии, а так же на старенькой карточке nvidia 8600G, купленной 2 года назад.  Дрова ставил сам с оф. сайта AMD, nVidia,  свободные дрова - в топку. И компиз не забывайте отключить, толку ноль, а ресурсы ест. Хорошо и полно тема раскрыта на ЛОР, там народ вовсю экспериментировал с тонкими настройками mPlayer
« Последнее редактирование: 09 Август 2010, 22:48:29 от gidiara »

gidiara

  • Пользователь
  • **
  • Сообщений: 59
  • Карма: +11/-22
    • Просмотр профиля
Re: HD Video
« Ответ #13 : 10 Август 2010, 14:26:45 »
http://www.forum.free-x.de/wbb/index.php?page=Thread&threadID=961
 Поможем друг другу смотреть Full HD! ;-)
« Последнее редактирование: 12 Август 2010, 12:19:29 от Hromin »

dmitry287

  • Старожил
  • ****
  • Сообщений: 361
  • Карма: +45/-2
    • Просмотр профиля
Re: HD Video
« Ответ #14 : 10 Август 2010, 16:10:06 »
У меня 2 компа,один AthlonII х4 620 2.6 ГГц,видеокарта ати HD4250 бортовая,4 Gb RAM,второй видеокарта ати HD4200 бортовая,процессор AMD AthlonII x2 245, 2.9 ГГц, ОЗУ 4гб,из них 512м в обоих случаях отдано видюхе,до недавнего времени был Intel Dual Core 5200 2.5 ГГц 2 Gb RAM,
видео бортовое Х4500 Интел,думаю все три варианта относятся к категории "нормальное железо",все видеокарты хоть и бортовые умеют аппаратно декодировать HD(по спецификации производителей).Ни на одной из этих машин Full HD в линуксе без бубнов и напильников не показывало,на винде работало все и без проблем.
« Последнее редактирование: 12 Август 2010, 12:20:32 от Hromin »
Gigabyte GA-790XTA-UD4,Athlon II x4 620 2.6 GHz,4Gb DDR3,Video Gigabyte GT240 512M,HDD 3x500 Gb & 160 Gb