Автор Тема: Помогите переписать скрипт установки принтера  (Прочитано 1178 раз)

Kamrad

  • Ветеран
  • *****
  • Сообщений: 599
  • Карма: +141/-11
  • Пингвиновод
    • Просмотр профиля
Доброго времени суток, друзья!
Некоторое время назад попался мне очень удачный скрипт (см. вложения), который беспроблемно прицеплял принтеры Canon на любые "бунты". Но вот оказия - данный скрипт был "завязан" на ресурс UbuntuOne, который теперь закрыт. Вопрос к программистам - как грамотно модифицировать скрипт, чтобы он обращался не к сетевому ресурсу, а к локальным файлам в домашнем каталоге?
Кто хочет на компьютере юзить, музить и вузить - пусть купит себе вульвузеллу!

"Linux используют ...э....энтузиасты, а нормальные люди работают на Windows! Вот представьте - приучили вы ребёнка работать с Linux, а придёт он в школу, где кругом Windows - и что он будет делать?!"

Azure

  • Глобальный модератор
  • Ветеран
  • *****
  • Сообщений: 2118
  • Карма: +275/-114
  • Обычно я му-р-р-р-чу
    • Просмотр профиля
    • Exilibris Web Development
Надеюсь Вы понмаете, что должны быть скачаны файлы драйверов? #ссылки на пакеты драйвера
declare -A URL_DRIVER=([amd64_common]='http://ubuntuone.com/2g7oXCm9Rcf4HkJjS7Elc8' \
[amd64_capt]='http://ubuntuone.com/7ToZZeZHWZofFAkwY47pbc' \
[i386_common]='http://ubuntuone.com/10zGk82nKCxo6AxQAqyEJC' \
[i386_capt]='http://ubuntuone.com/63Cleziglh9a6wMHnmZH5k')
а wgety без разницы откуда брать: из интернета или из локалки…

Kamrad

  • Ветеран
  • *****
  • Сообщений: 599
  • Карма: +141/-11
  • Пингвиновод
    • Просмотр профиля
Надеюсь Вы понмаете, что должны быть скачаны файлы драйверов?

Еффстеффственно! :)
Кто хочет на компьютере юзить, музить и вузить - пусть купит себе вульвузеллу!

"Linux используют ...э....энтузиасты, а нормальные люди работают на Windows! Вот представьте - приучили вы ребёнка работать с Linux, а придёт он в школу, где кругом Windows - и что он будет делать?!"

Brego

  • Ветеран
  • *****
  • Сообщений: 566
  • Карма: +93/-1
  • Перебьемся
    • Просмотр профиля
    • MintMem
Kamrad, глянул я скриптик, да.. Разбираться в чужом скрипте, да еще таком... излишне подробном, что ли, да еще тестировать его -- вряд ли кто, кроме его автора, возьмется.
Установить LBP2900 и его "родственников" с помощью последних каноновских дров (v260) и прилагаемого к ним руководства гораздо проще и быстрее :)
Я тут выложил "шпору" для себя и для "кому нужно".
Проверено на LM 16 Cinnamon, LM 17 Cinnamon и Matuntu-Tahr (сборке Ubuntu 14.04 c Mate 1.8). Не вижу никаких препятствий для того же на других "бунтах".
"Следующая эпоха началась с сожжения всех хроник вместе с хронистами". С. Лем