Автор Тема: Обновления ПО дистрибутива у которого закончилась поддержка  (Прочитано 21868 раз)

rawin

  • Новичок
  • *
  • Сообщений: 17
  • Карма: +0/-0
    • Просмотр профиля
Даже не ожидал что кто-то ответит, а уж тем более что так быстро ))) Спасибо :)

Теперь для того, чтобы ошибка пропала мне нужно удалить из источников

deb http://archive.getdeb.net/ubuntu natty-getdeb apps
deb http://archive.getdeb.net/ubuntu natty-getdeb games
deb http://extras.ubuntu.com/ubuntu natty main

Правильно? Что-то вредное из-за этого может произойти?

2 верхние отключил в менеджере программ последнего там нет... (или имеет другой вид) что отключить?
« Последнее редактирование: 07 Январь 2013, 22:56:36 от rawin »

Slen

  • Старожил
  • ****
  • Сообщений: 380
  • Карма: +39/-5
    • Просмотр профиля
    • Росинка ВКонтакте

Теперь для того, чтобы ошибка пропала мне нужно удалить из источников

deb http://archive.getdeb.net/ubuntu natty-getdeb apps
deb http://archive.getdeb.net/ubuntu natty-getdeb games

Правильно?
Удалять не обязательно, можно сделать так
http://rosinka.rosix.ru/index.php?topic=3338

По поводу версий у которых закончилась поддержка
Цитировать
Старые версии Ubuntu не поддерживаются Canonical, это означает, что все официальные репозитории для них заморожены и не пополняются обновлениями, устраняющими проблемы с безопасностью. Категорически не рекомендуется использовать неподдерживаемые версии Ubuntu.
Репозитории для неподдерживаемых версий
После окончания поддержки дистрибутива он удаляется с серверов, на которых хранятся репозитории Ubuntu. Это приводит к тому, что при попытке обновить список доступных пакетов выдаётся предупреждение о недоступности всех основных репозиториев. Однако все пакеты из репозитория на момент окончания поддержки не удаляются в никуда, а переводятся на другой сервер, поэтому если вам зачем-либо понадобится репозиторий для неподдерживаемой версии Ubuntu, вы сможете его получить. Для этого заменить все ссылки в файле /etc/apt/sources.list, отвечающие за официальные репозитории, на:
http://old-releases.ubuntu.comНет ни одной причины использовать неподдерживаемые версии Ubuntu. Архивные репозитории не обновляются и не содержат актуальных исправлений безопасности.
http://help.ubuntu.ru/wiki/old_ubuntu_versions
« Последнее редактирование: 08 Январь 2013, 00:32:53 от Slen »

Lerych

  • Ветеран
  • *****
  • Сообщений: 943
  • Карма: +122/-4
  • Выбрал Linux - включай мозг! ©
    • Просмотр профиля
Getdeb.net для всех дистров не работает, включая самые последние. Это у него традиция такая — с ним каждый год такое происходит. Можно просто на время отключить его репозитории, а потом, когда снова заработает, опять включить. Либо тупо забить и не обращать внимания на сии предупреждения системы при обновлении. Когда getdeb.net вернется к жизни, само пройдет. :-)

Ghost

  • Старожил
  • ****
  • Сообщений: 466
  • Карма: +31/-2
  • прошу не прибавлять и не убавлять мою карму
    • Просмотр профиля
Цитировать
2 верхние отключил в менеджере программ последнего там нет... (или имеет другой вид) что отключить?
Однако описано, что есть [spoiler]
Цитировать
rawin@rawin-AOD257 ~/Рабочий стол $ inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.rosix.ru/rosinka/ katya main
           deb http://packages.linuxmint.com/ katya main upstream import
           deb http://archive.ubuntu.com/ubuntu/ natty main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu/ natty-updates main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ natty-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ natty partner
           deb http://extras.ubuntu.com/ubuntu natty main
           deb http://packages.medibuntu.org/ natty free non-free
           deb http://archive.getdeb.net/ubuntu natty-getdeb apps
           deb http://archive.getdeb.net/ubuntu natty-getdeb games
           deb http://download.virtualbox.org/virtualbox/debian natty contrib
           deb http://ppa.launchpad.net/tualatrix/ppa/ubuntu natty main
           deb http://ppa.launchpad.net/andrew-crew-kuznetsov/xneur-stable/ubuntu natty main
           deb http://ppa.launchpad.net/qutim/qutim/ubuntu natty main
           deb http://ppa.launchpad.net/dockbar-main/ppa/ubuntu natty main
           deb http://ppa.launchpad.net/leolik/leolik/ubuntu natty main
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb http://dl.google.com/linux/chrome/deb/ stable main
rawin@rawin-AOD257 ~/Рабочий стол $
[/spoiler]
Можно зайти в /etc/apt/sources.list (к примеру открыть с правами администратора(root) файл sources.list) и там найти deb http://extras.ubuntu.com/ubuntu natty main

Slen

  • Старожил
  • ****
  • Сообщений: 380
  • Карма: +39/-5
    • Просмотр профиля
    • Росинка ВКонтакте
Вам правильно Ghost говорит, открываете sources.list
sudo gedit /etc/apt/sources.listИ ставите перед ним # (тогда обновлений с него не будет)
[spoiler]#deb http://extras.ubuntu.com/ubuntu natty main
#deb-src http://extras.ubuntu.com/ubuntu natty main [/spoiler]
« Последнее редактирование: 08 Январь 2013, 11:19:56 от Slen »

rawin

  • Новичок
  • *
  • Сообщений: 17
  • Карма: +0/-0
    • Просмотр профиля
ага, пасиб, еще вчера (вернее ночью) разобрался  поправил список пока все корректно

получилось что-то вроде:

sudo sed -i '12,95d' /etc/apt/sources.list
sudo gedit /etc/apt/sources.list
+ копипаст действующих реп сохранение  и
sudo apt-get update

забавно получается ))) когда появляется проблема смотришь на нее как на неразрешимую, а если кто-то начинает помогать цепляешься и все оказывается довольно просто )))
« Последнее редактирование: 08 Январь 2013, 19:58:49 от rawin »

ya

  • Постоялец
  • ***
  • Сообщений: 121
  • Карма: +2/-4
  • Я новичок в Linux Mint Росинке...
    • Просмотр профиля
Привет всем, у меня такая проблема: при обновлении стандартным менеджером обновлений выдаёт ошибку:
Не удалось получить http://extras.ubuntu.com/ubuntu/dists/natty/main/binary-i386/Packages  404  Not Found
Some index files failed to download. They have been ignored, or old ones used instead.
С чем это может быть связано? Спасибо.
====
Пользуемся Поиском
« Последнее редактирование: 22 Апрель 2013, 13:40:46 от Azure »

Ghost

  • Старожил
  • ****
  • Сообщений: 466
  • Карма: +31/-2
  • прошу не прибавлять и не убавлять мою карму
    • Просмотр профиля
с тем что дистр уже не поодерживается

vita

  • Гость
С чем это может быть связано?
Ubuntu 11.04 Natty не поддерживается уже около года, но если в системе всё устраивает, то можно ею пользоваться и без обновлений достаточно долгое время.

Ghost

  • Старожил
  • ****
  • Сообщений: 466
  • Карма: +31/-2
  • прошу не прибавлять и не убавлять мою карму
    • Просмотр профиля
Ну вы и переборщили )))... Окончание срока поддержки октябрь 2012 года

mimoprohodil

  • Гость
Собственно весь вопрос в заголовке. Стоит Росинка 11. Буквально на днях запланировал поставить пару-тройку дополнительных пакетов. А мне в ответ apt-get вываливает 404 ошибку и вдогонку сообщает, что пакету доверять не стоит, так как он не прошёл проверку. WTF, господа-товарищи?
Открыл archive.ubuntu.com - нет там natty директории. С launchpad.net (или как его там) подобная ситуация. Так вот мыкался, мыкался с этой бедой - в итоге слетел гном и сетевые настройки (возможно что-то ещё, пока не проверял).
PS Существует ли альтернативный репозиторий?
PPS Есть ли возможность восстановить прежнее состояние системы? (бекапы, конечно же, не делались)
PPPS Слышал что поддержка natty прекратилась, но зачем удалять директорию?
PPPPS провайдер - жёлто-полосатый
« Последнее редактирование: 30 Июнь 2013, 12:40:32 от mimoprohodil »

Kamrad

  • Ветеран
  • *****
  • Сообщений: 599
  • Карма: +141/-11
  • Пингвиновод
    • Просмотр профиля
"Лошадь сдохла - слезь!" :)
P.S. Используйте дистрибутивы, жизненный цикл которых не закончился.
Кто хочет на компьютере юзить, музить и вузить - пусть купит себе вульвузеллу!

"Linux используют ...э....энтузиасты, а нормальные люди работают на Windows! Вот представьте - приучили вы ребёнка работать с Linux, а придёт он в школу, где кругом Windows - и что он будет делать?!"

mimoprohodil

  • Гость
"Лошадь сдохла - слезь!" :)
P.S. Используйте дистрибутивы, жизненный цикл которых не закончился.
Ну вы молодца, чо. Ценность вашего комментария измерению не поддаётся.
Зачем тогда настраивать и отлаживать систему, если она когда-нибудь всё равно сдохнет?
Я своей месяца три только попользовался - и вот - накуси.
С предыдущей росинкой такая же бяка была - после очередного обновления - слетело подключение к интернету. А без интернета жизни у линукс нет.

Kamrad

  • Ветеран
  • *****
  • Сообщений: 599
  • Карма: +141/-11
  • Пингвиновод
    • Просмотр профиля
Вы совершенно правы - без полноценного доступа в сеть линукс действительно импотентен. Впрочем, как и MacOS. Увы, не моя злая воля, что циклы "жизни" дистрибутивов ограничены. Прибавьте к этому, что Гном 2, который идёт в "Росинке", тоже угробили. Если вы отладили и собрали систему, то на кой чёрт вам там что-то менять? ;) Я вон тестю в своё время настроил Мандриву 2008, так он до сих пор ей пользуется, ничего не меняет - и доволен -, хотя "тетя Маня" давно уже копыта откинула - и фактически, и юридически. А если тянет что-то изменять - берите более свежий дистрибутив, чьи "репы" ещё живы.
Кто хочет на компьютере юзить, музить и вузить - пусть купит себе вульвузеллу!

"Linux используют ...э....энтузиасты, а нормальные люди работают на Windows! Вот представьте - приучили вы ребёнка работать с Linux, а придёт он в школу, где кругом Windows - и что он будет делать?!"

Single

  • Пользователь
  • **
  • Сообщений: 63
  • Карма: +2/-0
  • LMDE x86 @ HP620 Laptop
    • Просмотр профиля
Вас что, на гугле забанили?

Всё лежит на http://old-releases.ubuntu.com/ubuntu/dists/

В sources.list нужно добавить следующее:
# Основное, необходимо
deb http://old-releases.ubuntu.com/ubuntu/ natty main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ natty-updates main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ natty-security main restricted universe multiverse

# Опционально, бэкпорты. В общем-то тоже рекомендуется.
deb http://old-releases.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse
# Предлагаемые обновления
#deb http://old-releases.ubuntu.com/ubuntu/ natty-proposed main restricted universe multiverse

Ну и, естественно,
sudo apt-get update

Удачи!
« Последнее редактирование: 01 Июль 2013, 11:37:54 от Single »
Мечтай так, как будто будешь жить вечно. Живи так, как будто умрешь завтра.