Автор Тема: Проблема с зависимостями ... после обновления...  (Прочитано 8960 раз)

Serg

  • Постоялец
  • ***
  • Сообщений: 193
  • Карма: +32/-5
    • Просмотр профиля
Короче вот такая вот бочина:
sergey@H-4385 ~ $ sudo aptitude upgrade
W: The "upgrade" command is deprecated; use "safe-upgrade" instead.
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях     
Инициализация состояний пакетов... Готово         
Следующие частично установленные пакеты будут настроены:
  samba samba-common samba-common-bin
0 пакетов обновлено, 0 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 0Б архивов. После распаковки 0Б будет занято.
Настраивается пакет samba-common (2:3.4.7~dfsg-1ubuntu3.2) ...
dpkg: не удалось обработать параметр samba-common (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10
dpkg: зависимости пакетов не позволяют настроить пакет samba-common-bin:
 samba-common-bin зависит от samba-common (>= 2:3.4.0~pre1-2), однако:
  Пакет samba-common пока не настроен.
dpkg: не удалось обработать параметр samba-common-bin (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет samba:
 samba зависит от samba-common (= 2:3.4.7~dfsg-1ubuntu3.2), однако:
  Пакет samba-common пока не настроен.
 samba зависит от samba-common-bin, однако:
  Пакет samba-common-bin пока не н�Отчет apport не записан, т.к. сообщение об ошибке указывает на предыдущий сбой
                                 Отчет apport не записан, т.к. сообщение об ошибке указывает на предыдущий сбой
                               �строен.
dpkg: не удалось обработать параметр samba (--configure):
 проблемы зависимостей -- оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 samba-common
 samba-common-bin
 samba
E: Sub-process /usr/bin/dpkg returned an error code (1)
Не удалось установить пакет.  Попытка восстановить:
Настраивается пакет samba-common (2:3.4.7~dfsg-1ubuntu3.2) ...
dpkg: не удалось обработать параметр samba-common (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10
dpkg: зависимости пакетов не позволяют настроить пакет samba-common-bin:
 samba-common-bin зависит от samba-common (>= 2:3.4.0~pre1-2), однако:
  Пакет samba-common пока не настроен.
dpkg: не удалось обработать параметр samba-common-bin (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет samba:
 samba зависит от samba-common (= 2:3.4.7~dfsg-1ubuntu3.2), однако:
  Пакет samba-common пока не настроен.
 samba зависит от samba-common-bin, однако:
  Пакет samba-common-bin пока не настроен.
dpkg: не удалось обработать параметр samba (--configure):
 проблемы зависимостей -- оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 samba-common
 samba-common-bin
 samba
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях       
Инициализация состояний пакетов... Готово         

Все началось с того, что при полном обновлении как то криво обновился samba и теперь сообщение об ошибке появляется при каждом обновлении или установке софта.
Пакеты самбы удалял ... чистил систему от остатков ... и ставил назад .... не помогло ...

SASHOK

  • Пользователь
  • **
  • Сообщений: 58
  • Карма: +11/-3
    • Просмотр профиля
В терминал: sudo dpkg --configure -a
sudo apt-get update
sudo apt-get install -f
Если проблема не разрешилась
  • ребут
  • при выборе ОС выбери  Recovery Mode
  • в появившемся меню выбери "dpkg Repair broken packages/функция восстановления поврежденных пакетов/"
  • ребут.
« Последнее редактирование: 19 Март 2011, 14:09:22 от Azure »

fire55

  • Новичок
  • *
  • Сообщений: 3
  • Карма: +0/-0
    • Просмотр профиля
Обновление Debian Mint 10
« Ответ #2 : 17 Март 2011, 01:45:32 »
При обновлении Debian Mint 10, через утилиту mintupdate пишет  ошибку "Невозможно выполнить изменения! Сначала необходимо исправить проблемы в зависимостях." ?
Даже после переустаноке не помогла, даже после установке на вторую машину таже ошибка, я обновлял минт сразу после установки.

Azure

  • Глобальный модератор
  • Ветеран
  • *****
  • Сообщений: 2118
  • Карма: +275/-114
  • Обычно я му-р-р-р-чу
    • Просмотр профиля
    • Exilibris Web Development
2 fire55 Поиском пользуйтесь! (вверху справа окошечко)

Serg_Grey

  • Новичок
  • *
  • Сообщений: 1
  • Карма: +0/-0
  • Я новичок в Linux Mint Росинке...
    • Просмотр профиля
Ошибка операции над пакетом
« Ответ #4 : 19 Декабрь 2013, 13:07:34 »
Добрый день!
При обновлении Ubuntu 12.04 вышло сообщение
"Ошибка операции над пакетом
Установка или удаление пакетов программ не удалось."
Подробнее - "Errors were encountered while processing:
 /var/cache/apt/archives/linux-firmware_1.79.9_all.deb
Error in function:
SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)".

Как это победить? На компе перестал работать Wi-Fi (не видит сеть), проводной Интернет работает.